よくある質問

サポートされている言語が終了することはありますか?

(:更新)

対応言語のサポート終了はCloud Foundryコミュニティに従いますが、基本的には対応言語/ミドルウェアのオープンソースとしてのサポートが続く限り、サポートしています。
(2016年6月現在でもTomcat6が動作するなど、サポート期間はかなり長期です)

また対応言語のオープンソースとしてのサポートが終了してしばらく経過した場合、Cloud Foundryのサポートも終了する可能性はありますが、この場合でも稼働中のECL PaaS上のアプリケーションが突然動作を停止することはありません。新規にデプロイ(push)する際にエラーが発生する形になりますが、お客様側でBuildpackを準備すれば半永久的に利用可能です。

ただし、ECL PaaSやCloud Foundryの利用有無にかかわらず、サポートが終了したミドルウェア/言語は脆弱性が発見されてもパッチが提供されませんので、基本的には新バージョンに移行することをお勧めします。

このFAQは参考になりましたか?

参考になった 参考にならなかった

サービスの改善にご協力をお願いいたします

こちらのFAQは参考になりましたか? ご意見がございましたら、ぜひお聞かせください。

ありがとうございました

ご意見は送信されました。