優先制御設定

動作確認バージョン: vSRX Version15.1X49-D105.1, vSRX Version19.2R1.8

ここでは、インターフェイスから送出されるトラフィックを優先制御するための設定を紹介します。

特定のIPアドレスの通信を優先させてドロップさせない設定

サンプル設定のシナリオ

  • インターフェイス(ge-0/0/1)から送出されるトラフィックに対して設定したい
  • インターフェイス(ge-0/0/1)の制限帯域は10Mbpsにしたい
  • インターフェイス(ge-0/0/1)で10Mbps以上のトラフィックを出力する時に仮想サーバ(192.168.1.11)からの通信を最優先にしてドロップしないようにしたい
vsrx_pq_fig1.png

シナリオにおける設定のながれ

トラフィックの入力インターフェイスでパケットの分類ができるようにしておき、出力インターフェイスでプライオリティに基づいた優先制御を設定するながれです。

1.仮想サーバ(192.168.1.11)からの通信に対するフィルタ名 QOS_STRICT を作成
2.仮想サーバ(192.168.3.13)からの通信に対するフィルタ名 QOS_AF を作成
3.送信元IPアドレス192.168.1.0/24に該当する通信(パケット)は、Forwarding classを expedited-forwarding にして QOS_STRICT に設定
4.送信元IPアドレス192.168.3.0/24に該当する通信(パケット)は、Forwarding classを assured-forwarding にして QOS_AF に設定
5.インターフェイス(ge-0/0/0)に QOF_STRICT インターフェイス(ge-0/0/2)に QOS_AF のフィルタを適用
6.スケジューラ STRICT を設定し上限帯域を2.1Mbpsプライオリティを strict-high に設定
7.スケジューラ AF を設定しプライオリティを low に設定
8.スケジューラマップ SCHE を設定し expedited-forwarding にスケジューラ STRICT を設定
9.スケジューラマップ SCHE を設定し assured-forwarding にスケジューラ AF を設定
10.スケジューラマップ SCHE は帯域上限値を10Mbpsに設定
11.インターフェイス(ge-0/0/1)はスケジューラ動作させる設定

CLIにて入力するコマンド

user01@vSRX-02# set firewall filter QOS_STRICT term 1 from source-address 192.168.1.0/24
user01@vSRX-02# set firewall filter QOS_STRICT term 1 then loss-priority low
user01@vSRX-02# set firewall filter QOS_STRICT term 1 then forwarding-class expedited-forwarding
user01@vSRX-02# set firewall filter QOS_STRICT term 1 then accept
user01@vSRX-02# set firewall filter QOS_STRICT term 2 then accept
user01@vSRX-02# set firewall filter QOS_AF term 1 from source-address 192.168.3.0/24
user01@vSRX-02# set firewall filter QOS_AF term 1 then loss-priority high
user01@vSRX-02# set firewall filter QOS_AF term 1 then forwarding-class assured-forwarding
user01@vSRX-02# set firewall filter QOS_AF term 1 then accept
user01@vSRX-02# set firewall filter QOS_AF term 2 then accept
user01@vSRX-02# set interfaces ge-0/0/0 unit 0 family inet filter input QOS_STRICT
user01@vSRX-02# set interfaces ge-0/0/2 unit 0 family inet filter input QOS_AF
user01@vSRX-02# set class-of-service schedulers STRICT shaping-rate 2100000
user01@vSRX-02# set class-of-service schedulers STRICT priority strict-high
user01@vSRX-02# set class-of-service schedulers AF priority low
user01@vSRX-02# set class-of-service scheduler-maps SCHE forwarding-class expedited-forwarding scheduler STRICT
user01@vSRX-02# set class-of-service scheduler-maps SCHE forwarding-class assured-forwarding scheduler AF
user01@vSRX-02# set class-of-service interfaces ge-0/0/1 unit 0 scheduler-map SCHE shaping-rate 10m
user01@vSRX-02# set class-of-service interfaces ge-0/0/1 unit 0 rewrite-rules dscp default
user01@vSRX-02# set interfaces ge-0/0/1 per-unit-scheduler

正しく設定が完了したときのコンフィグレーションは次のとおりです。

interfaces {
    ge-0/0/0 {
        unit 0 {
            family inet {
                filter {
                    input QOS_STRICT;
                }
                address 192.168.1.102/24;
            }
        }
    }
    ge-0/0/1 {
        per-unit-scheduler;
        unit 0 {
            family inet {
                address 192.168.2.102/24;
            }
        }
    }
    ge-0/0/2 {
        unit 0 {
            family inet {
                filter {
                    input QOS_AF;
                }
                address 192.168.3.102/24;
            }
        }
    }
}
class-of-service {
    interfaces {
        ge-0/0/1 {
            unit 0 {
                scheduler-map SCHE;
                shaping-rate 10m;
                rewrite-rules {
                    dscp default;
                }
            }
        }
    }
    scheduler-maps {
        SCHE {
            forwarding-class expedited-forwarding scheduler STRICT;
            forwarding-class assured-forwarding scheduler AF;
        }
    }
    schedulers {
        STRICT {
            shaping-rate 2100000;
            priority strict-high;
        }
        AF {
            priority low;
        }
    }
}
firewall {
    filter QOS_STRICT {
        term 1 {
            from {
                source-address {
                    192.168.1.0/24;
                }
            }
            then {
                loss-priority low;
                forwarding-class expedited-forwarding;
                accept;
            }
        }
        term 2 {
            then accept;
        }
    }
    filter QOS_AF {
        term 1 {
            from {
                source-address {
                    192.168.3.0/24;
                }
            }
            then {
                loss-priority high;
                forwarding-class assured-forwarding;
                accept;
            }
        }
        term 2 {
            then accept;
        }
    }
}

動作確認結果

以下の検証結果ログから、仮想サーバ(192.168.3.13)から仮想サーバ(192.168.2.14)へトラフィックを流し、仮想サーバ(192.168.1.11)から仮想サーバ(192.168.2.12)へ優先トラフィックを割り込ませて制限帯域(10Mbps)を超過させた場合に、優先トラフィックのパケットがドロップしないことが確認できました。

vSRXのインターフェイス(ge-0/0/1)での出力状況

user01@vSRX-02> show interfaces queue ge-0/0/1 | no-more
Physical interface: ge-0/0/1, Enabled, Physical link is Up
  Interface index: 136, SNMP ifIndex: 520
Forwarding classes: 8 supported, 4 in use
Egress queues: 8 supported, 4 in use
Queue: 0, Forwarding classes: best-effort
  omitted
Queue: 1, Forwarding classes: expedited-forwarding
  Queued:
    Packets              :                  5105                     0 pps
    Bytes                :               7718760                     0 bps
  Transmitted:
    Packets              :                  5105                     0 pps
    Bytes                :               7718760                     0 bps
    Tail-dropped packets :                     0                     0 pps
    RL-dropped packets   :                     0                     0 pps
    RL-dropped bytes     :                     0                     0 bps
    RED-dropped packets  :                     0                     0 pps
     Low                 :                     0                     0 pps
     Medium-low          :                     0                     0 pps
     Medium-high         :                     0                     0 pps
     High                :                     0                     0 pps
    RED-dropped bytes    :                     0                     0 bps
     Low                 :                     0                     0 bps
     Medium-low          :                     0                     0 bps
     Medium-high         :                     0                     0 bps
     High                :                     0                     0 bps
  Queue Buffer Usage:
    Reserved buffer      :                625000 bytes
  Queue-depth bytes      :
    Current              :                     0
Queue: 2, Forwarding classes: assured-forwarding
  Queued:
    Packets              :                 51025                    15 pps
    Bytes                :              77149800                193432 bps
  Transmitted:
    Packets              :                 44792                   230 pps
    Bytes                :              67725504               2792776 bps
    Tail-dropped packets :                  2877                     0 pps
    RL-dropped packets   :                     0                     0 pps
    RL-dropped bytes     :                     0                     0 bps
    RED-dropped packets  :                  3356                     0 pps
     Low                 :                     0                     0 pps
     Medium-low          :                     0                     0 pps
     Medium-high         :                     0                     0 pps
     High                :                  3356                     0 pps
    RED-dropped bytes    :               5074272                  6040 bps
     Low                 :                     0                     0 bps
     Medium-low          :                     0                     0 bps
     Medium-high         :                     0                     0 bps
     High                :               5074272                  6040 bps
  Queue Buffer Usage:
    Reserved buffer      :                625000 bytes
  Queue-depth bytes      :
    Current              :                     0
Queue: 3, Forwarding classes: network-control
  omitted

仮想サーバ(192.168.1.11)から仮想サーバ(192.168.2.12)宛てに2MbpsのTrafficを印加した時のログ

vsrx_pq_fig2.png

仮想サーバ(192.168.3.13)から仮想サーバ(192.168.2.14)宛てに10MbpsのTrafficを印加した時のログ

vsrx_pq_fig3.png