帯域制限(上限値)設定

動作確認バージョン: vSRX Version15.1X49-D105.1, vSRX Version19.2R1.8

ここでは、インターフェイスを通過するトラフィックの帯域制限するための設定を紹介します。

特定の送信元IPアドレスの通信を100Mbpsに制限する設定

サンプルのシナリオ

  • インターフェイス(ge-0/0/1)を通過するトラフィックを合計100Mbpsに制限したい
  • インターフェイス(ge-0/0/1)で帯域制限を設定したい
vsrx_policing_fig1

シナリオにおける設定のながれ

1.設定するポリシー名を LIMIT_100M として設定
2.設定したポリシー LIMIT_100M に対して制限する帯域(100Mbps)を設定
3.インターフェイス(ge-0/0/1)にて LIMIT_100M を適用

CLIにて入力するコマンド

user01@vSRX-02# set firewall policer LIMIT_100M filter-specific
user01@vSRX-02# set firewall policer LIMIT_100M logical-interface-policer
user01@vSRX-02# set firewall policer LIMIT_100M if-exceeding bandwidth-limit 100m
user01@vSRX-02# set firewall policer LIMIT_100M if-exceeding burst-size-limit 1250000
user01@vSRX-02# set firewall policer LIMIT_100M then discard
user01@vSRX-02# set interfaces ge-0/0/1 unit 0 family inet policer input LIMIT_100M

正しく設定が完了したときのコンフィグレーションは次のとおりです。

interfaces {
    ge-0/0/1 {
       unit 0 {
           family inet {
               policer {
                   input LIMIT_100M;
               }
           }
       }
    }
    ge-0/0/2 {
       unit 0 {
           family inet {
               address 192.168.3.102/24;
           }
       }
    }
}
firewall {
    policer LIMIT_100M {
        filter-specific;
        logical-interface-policer;
        if-exceeding {
            bandwidth-limit 100m;
            burst-size-limit 1250000;
        }
        then discard;
   }
}

動作確認結果

以下の検証結果ログから、仮想サーバ(192.168.2.12)から仮想サーバ(192.168.3.13)宛てのTraffic 1Gbpsを印加した際に98.3Mbpsの結果が得られたため帯域制御がされていることが確認できました。

1Gbps送出した仮想サーバ(192.168.2.12)のiperf結果

[user01@centsv-02 ~]$  iperf -c 192.168.3.13 -t 60 -u -b 1G -i 20
------------------------------------------------------------
Client connecting to 192.168.3.13, UDP port 5001
Sending 1470 byte datagrams, IPG target: 10.95 us (kalman adjust)
UDP buffer size:  208 KByte (default)
------------------------------------------------------------
[  3] local 192.168.2.12 port 38812 connected with 192.168.3.13 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-20.0 sec  2.50 GBytes  1.07 Gbits/sec
[  3] 20.0-40.0 sec  2.50 GBytes  1.07 Gbits/sec
[  3]  0.0-60.0 sec  7.50 GBytes  1.07 Gbits/sec
[  3] Sent 5478275 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   703 MBytes  98.3 Mbits/sec   0.000 ms 4976864/5478275 (0%)
[  3] 0.00-60.00 sec  3 datagrams received out-of-order
[user01@centsv-02 ~]$

1Gbps受信した仮想サーバ(192.168.3.13)のiperf結果

[user01@centsv-03 ~]$ iperf -s -u
------------------------------------------------------------
Server listening on UDP port 5001
Receiving 1470 byte datagrams
UDP buffer size:  208 KByte (default)
------------------------------------------------------------
[  3] local 192.168.3.13 port 5001 connected with 192.168.2.12 port 38812
[ ID] Interval       Transfer     Bandwidth        Jitter   Lost/Total Datagrams
[  3]  0.0-60.0 sec   703 MBytes  98.3 Mbits/sec   0.033 ms 4976864/5478275 (91%)
[  3] 0.00-60.00 sec  3 datagrams received out-of-order

1Gbpsのトラフィック印加中のvSRXインターフェイスの状態

vsrx_policing_fig2